Dual Band WiFi 5 Repeater

Dual Band WiFi 5 Repeater

Product Highlights
● Extend the range of existing Wi-Fi to provide greater coverage and improve connectivity.
● Wall-mount Design
● With High gain Antennas
● With smart light Indicator
● With WPS button
Category
WiFi 5 Repeater
 
Send Inquiry
Features
Specification
FAQ

Features

 

 

DWR-C5400M

 

DCOM Technology Wi-Fi range extender allows you to extend the range of your existing Wi-Fi to provide greater coverage, improve connectivity and help eliminate Wi-Fi black spots. It works with any universal Wi-Fi routers.

 

DWR-C5400M is a Wi-Fi range extender supports wireless speeds of up to 300Mbps (802.11N mode) and 866Mbps (802.11AC mode), allows you to extend the range of your existing Wi-Fi to provide greater coverage, improve connectivity and help eliminate Wi-Fi black spots. It works with any universal Wi-Fi routers. This extender equips a well-designed web setup wizard, which makes the configuration run at the optimum speed.


This Dual band Wi-Fi 5 Repeater is an ideal wireless broadband solution for both home users who wish to share high-speed wireless Internet access and small offices which wish to do business on the Internet.

1. Wall-mount Design

This Dual band Wi-Fi 5 Repeater With a small size, it is easy to plug the extender into the electrical outlet.

2. High gain Antennas

This Dual band Wi-Fi 5 Repeater Equipped with 2 external antennas, the extender can enhance the signal strength of the existing network.

3. Smart light Indicator

Smart LED indicators indicate the signal strength with different colors and help find the best placement for Wi-Fi coverage.

4. WPS Button

Press the WPS button for easy setup without reconfiguration.

5. Additional Ethernet Port

This Dual band Wi-Fi 5 Repeater with Ethernet port, the extender can be connected to any wired devices.

 

Parameter

 

 

Description

Wi-Fi5 Repeater

Wireless Speed

2.4GHz 300Mbps

5.8GHz 866Mbps

Standard

802.11a/b/g/n/ac

Frequency

2.4GHz & 5.8GHz

Transmission Power (Max)

2.4GHz:22dbm

5.8GHz:20dbm

Interface

1*FE LAN

Antenna

2*3dbi fixed

WAN Mode

Repeater

Feature and Technology Spec

Protocol

= IEEE 802.11a/b/g/n
= IEEE 802.11ac
= RFC768 User Datagram Protocol (UDP)
= RFC791 Internet Protocol ( IP)
= RFC792 Internet Control Message Protocol (ICMP)
= RFC793 Transmission Control Protocol (TCP)
= RFC826 Address Resolution Protocol (ARP)
= RFC2131 Dynamic Host Configuration Protocol (DHCP)

System Support

Windows 98SE, Windows 2000, Windows ME, Windows XP 32/64 bit

and Windows Vista 32/64bit

WLAN

Support 20MHz,40MHz,80MHz in 5GHz band
Support 20/40MHz in 2.4GHz band
Support 11AC 2T2R mode with data rate up to 867Mbps
Support 11N 2T2R mode with data rate up to 300Mbps
Support 256/64/16/8-QAM, QPSK, BPSK, MCS0 ~ MCS15

Encryption

4/128 bit, WEP, WPA, and WPA2 wireless encryption

QoS

Non-support

SNMPv2 or v3

Non-Support

Ethernet Interfaces

1 x RJ45 for 10/100Mbps Ethernet Port(option)

LEDs

l Power, Router, Ethernet, WPS (green color)
l Position indicators- Red: too close &too far; Blue: good to catch router signal

Buttons

l Power(on/off)
l WPS
l Band Selection
l Reset (Pinhole)

Consumption

12W

Environment Requirement

Operating Temperature

0ºC~45ºC

Storage Temperature

-20ºC~70ºC

Operating Humidity

10%~90%, non-condensing

Storage Humidity

5%~90%, non-condensing

Power Supply

Built-in Power Supply

EMC and Safety

Regulatory Compliance

CE

Safety Regulations

FCC

Green Standard

RoHS

Physical Dimension

Physical Characteristics

L x W x H: 100 mm x 70 mm x 75 mm

Weight

100g

FAQ

Q: How to load default settings after a configuration error?

Answer: To restore factory default settings, turn on the device and press the reset button for about 1 second, then release it.
The default IP address and subnet mask of the DSL router are 192.168.1.1 and 255.255.255.0, respectively. Please find the default username and password on the sticker at the bottom of the device.

Q: What should I do if I cannot log into the router's web UI?

Answer: Try the following solutions and log in again:
● Make sure your Ethernet cable with an internet connection is plugged into the WAN port of the router, not the LAN port.
● Make sure your wireless device is connected to the router's SSID.
● Ensure that your wired devices are properly connected to the router's ports 1, 2, or 3/IPTV via Ethernet cables. Also, make sure the devices are set to automatically obtain an IP address and automatically obtain DNS server addresses.
● Change the web browser and then log in again.
● Reset the router and log in again.

Hot Tags: dual band wifi 5 repeater, China dual band wifi 5 repeater manufacturers, Dual Band WiFi 5 Repeater, wifi 5 repeater, wifi repeater

Send Inquiry
Contact usif have any question

You can either contact us via phone, email or online form below. Our specialist will contact you back shortly.

Contact now!